Setting up FinchVPN on Linuxmint-18 Sarah

I cannot get this vpn to work on linuxmint-18 Sarah. any help?

1 Like

Hi,

May I know what problem are you facing with it?

1 Like

I am a linux user (currently linuxmint-18, Sarah); your youtube guide is for gnome network manager and my system does not have certain files that you talk about there. I cannot even set up a new VPN using network manager at rght bottom panel.

1 Like

Hi,

Understand, we will notify related team to work up an installation guide for FinchVPN on linuxmint-18 :slight_smile:

Will let you know once it had made available.

1 Like

when I try to set up vpn by clicking on the network applet in the panel, I get the message “The file ‘FinchVPN_EU_Netherlands_06_udp_8484_linux.ovpn’ could not be read or does not contain recognized VPN connection information” --“Error: Key file contains line ‘client’ which is not a key-value pair, group, or comment.”

What do I do?

1 Like

Could you show me a screenshot for this?

You could try this guide https://www.finchvpn.com/guide/linuxmint/openvpn that are currently partially done. Our staffs are working on finalizing it.

1 Like

Hello,

My October 2015 Finch Subscription was quite useless to me as I could not set up VPN on my Linux machine. I could use it on my android. Now in January 2017 I have decided to give it another go and took a three months premier subscription. I am again floored. I cannot set up VPN. The guide you have published in ttps://www.finchvpn.com/guide/linuxmint/openvpn contains screenshots that are very different from the screens that pop up on my linuxmint Sarah 18. I have done my best but I do make any head way. MY syslog is below:

[email protected] ~ $ grep VPN /var/log/syslog
Jan 14 07:55:52 firstuser-PC NetworkManager[852]: [1484360752.9463] audit: op=“connection-delete” uuid=“1d28fcf4-0f05-491b-be56-40057517eae1” name=“VPN connection 1” pid=2412 uid=1000 result="success"
Jan 14 08:02:12 firstuser-PC NetworkManager[852]: [1484361132.9192] keyfile: add connection /etc/NetworkManager/system-connections/FinchVPN (f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”)
Jan 14 08:02:12 firstuser-PC NetworkManager[852]: [1484361132.9195] audit: op=“connection-add” uuid=“f936dd31-71a7-4ec9-b62b-163df07268e5” name=“FinchVPN” pid=3828 uid=1000 result="success"
Jan 14 08:05:16 firstuser-PC NetworkManager[852]: [1484361316.0323] keyfile: update /etc/NetworkManager/system-connections/FinchVPN (f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”)
Jan 14 08:05:16 firstuser-PC NetworkManager[852]: [1484361316.0327] audit: op=“connection-update” uuid=“f936dd31-71a7-4ec9-b62b-163df07268e5” name=“FinchVPN” pid=3828 uid=1000 result="success"
Jan 14 08:05:25 firstuser-PC NetworkManager[852]: [1484361325.1831] audit: op=“connection-activate” uuid=“f936dd31-71a7-4ec9-b62b-163df07268e5” name=“FinchVPN” pid=1660 uid=1000 result="success"
Jan 14 08:05:25 firstuser-PC NetworkManager[852]: [1484361325.2006] vpn-connection[0xbbc1d0,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: Started the VPN service, PID 4466
Jan 14 08:05:25 firstuser-PC NetworkManager[852]: [1484361325.2097] vpn-connection[0xbbc1d0,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: Saw the service appear; activating connection
Jan 14 08:05:25 firstuser-PC NetworkManager[852]: [1484361325.2518] vpn-connection[0xbbc1d0,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: VPN plugin: state changed: starting (3)
Jan 14 08:05:25 firstuser-PC NetworkManager[852]: [1484361325.2518] vpn-connection[0xbbc1d0,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: VPN connection: (ConnectInteractive) reply received
Jan 14 08:05:25 firstuser-PC nm-openvpn[4473]: OpenVPN 2.3.10 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [PKCS11] [MH] [IPv6] built on Feb 2 2016
Jan 14 08:05:25 firstuser-PC nm-openvpn[4473]: Control Channel Authentication: using ‘/home/firstuser/Desktop/Finch/finchvpn-tls-key.key’ as a OpenVPN static key file
Jan 14 08:06:25 firstuser-PC NetworkManager[852]: [1484361385.1540] vpn-connection[0xbbc1d0,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: VPN connection: connect timeout exceeded.
Jan 14 08:06:25 firstuser-PC NetworkManager[852]: [1484361385.1567] vpn-connection[0xbbc1d0,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: VPN plugin: failed: connect-failed (1)
Jan 14 08:06:25 firstuser-PC NetworkManager[852]: [1484361385.1576] vpn-connection[0xbbc1d0,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: VPN plugin: state changed: stopping (5)
Jan 14 08:06:25 firstuser-PC NetworkManager[852]: [1484361385.1577] vpn-connection[0xbbc1d0,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: VPN plugin: state changed: stopped (6)
Jan 14 08:07:03 firstuser-PC NetworkManager[852]: [1484361423.8246] audit: op=“connection-activate” uuid=“f936dd31-71a7-4ec9-b62b-163df07268e5” name=“FinchVPN” pid=1660 uid=1000 result="success"
Jan 14 08:07:03 firstuser-PC NetworkManager[852]: [1484361423.8318] vpn-connection[0xbbc3c0,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: Started the VPN service, PID 4596
Jan 14 08:07:03 firstuser-PC NetworkManager[852]: [1484361423.8411] vpn-connection[0xbbc3c0,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: Saw the service appear; activating connection
Jan 14 08:07:03 firstuser-PC nm-openvpn[4604]: OpenVPN 2.3.10 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [PKCS11] [MH] [IPv6] built on Feb 2 2016
Jan 14 08:07:03 firstuser-PC NetworkManager[852]: [1484361423.8858] vpn-connection[0xbbc3c0,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: VPN plugin: state changed: starting (3)
Jan 14 08:07:03 firstuser-PC NetworkManager[852]: [1484361423.8858] vpn-connection[0xbbc3c0,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: VPN connection: (ConnectInteractive) reply received
Jan 14 08:07:04 firstuser-PC nm-openvpn[4604]: Control Channel Authentication: using ‘/home/firstuser/Desktop/Finch/finchvpn-tls-key.key’ as a OpenVPN static key file
Jan 14 08:07:59 firstuser-PC NetworkManager[852]: [1484361479.7429] keyfile: update /etc/NetworkManager/system-connections/FinchVPN (f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”)
Jan 14 08:07:59 firstuser-PC NetworkManager[852]: [1484361479.7434] audit: op=“connection-update” uuid=“f936dd31-71a7-4ec9-b62b-163df07268e5” name=“FinchVPN” pid=3828 uid=1000 result="success"
Jan 14 08:08:04 firstuser-PC NetworkManager[852]: [1484361484.1514] vpn-connection[0xbbc3c0,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: VPN connection: connect timeout exceeded.
Jan 14 08:08:04 firstuser-PC NetworkManager[852]: [1484361484.1554] vpn-connection[0xbbc3c0,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: VPN plugin: failed: connect-failed (1)
Jan 14 08:08:04 firstuser-PC NetworkManager[852]: [1484361484.1555] vpn-connection[0xbbc3c0,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: VPN plugin: state changed: stopping (5)
Jan 14 08:08:04 firstuser-PC NetworkManager[852]: [1484361484.1559] vpn-connection[0xbbc3c0,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: VPN plugin: state changed: stopped (6)
Jan 14 08:10:29 firstuser-PC NetworkManager[852]: [1484361629.8862] keyfile: update /etc/NetworkManager/system-connections/FinchVPN (f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”)
Jan 14 08:10:29 firstuser-PC NetworkManager[852]: [1484361629.8865] audit: op=“connection-update” uuid=“f936dd31-71a7-4ec9-b62b-163df07268e5” name=“FinchVPN” pid=3828 uid=1000 result="success"
Jan 14 08:11:19 firstuser-PC NetworkManager[5004]: [1484361679.1225] keyfile: new connection /etc/NetworkManager/system-connections/FinchVPN (f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”)
Jan 14 08:11:33 firstuser-PC NetworkManager[5004]: [1484361693.8993] keyfile: update /etc/NetworkManager/system-connections/FinchVPN (f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”)
Jan 14 08:11:33 firstuser-PC NetworkManager[5004]: [1484361693.8997] audit: op=“connection-update” uuid=“f936dd31-71a7-4ec9-b62b-163df07268e5” name=“FinchVPN” pid=5456 uid=1000 result="success"
Jan 14 08:11:44 firstuser-PC NetworkManager[5004]: [1484361704.6805] audit: op=“connection-activate” uuid=“f936dd31-71a7-4ec9-b62b-163df07268e5” name=“FinchVPN” pid=1660 uid=1000 result="success"
Jan 14 08:11:44 firstuser-PC NetworkManager[5004]: [1484361704.6866] vpn-connection[0x189f210,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: Started the VPN service, PID 5538
Jan 14 08:11:44 firstuser-PC NetworkManager[5004]: [1484361704.6950] vpn-connection[0x189f210,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: Saw the service appear; activating connection
Jan 14 08:11:44 firstuser-PC NetworkManager[5004]: [1484361704.7353] vpn-connection[0x189f210,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: VPN plugin: state changed: starting (3)
Jan 14 08:11:44 firstuser-PC NetworkManager[5004]: [1484361704.7353] vpn-connection[0x189f210,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: VPN connection: (ConnectInteractive) reply received
Jan 14 08:11:44 firstuser-PC nm-openvpn[5545]: OpenVPN 2.3.10 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [PKCS11] [MH] [IPv6] built on Feb 2 2016
Jan 14 08:11:44 firstuser-PC nm-openvpn[5545]: Control Channel Authentication: using ‘/home/firstuser/Desktop/Finch/finchvpn-tls-key.key’ as a OpenVPN static key file
Jan 14 08:11:51 firstuser-PC NetworkManager[5004]: [1484361711.2015] vpn-connection[0x189f210,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: VPN plugin: requested secrets; state connect (4)
Jan 14 08:11:56 firstuser-PC NetworkManager[5004]: [1484361716.5653] vpn-connection[0x189f210,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: VPN plugin: requested secrets; state connect (4)
Jan 14 08:12:01 firstuser-PC NetworkManager[5004]: [1484361721.5273] vpn-connection[0x189f210,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: VPN plugin: requested secrets; state connect (4)
Jan 14 08:12:06 firstuser-PC NetworkManager[5004]: [1484361726.5695] vpn-connection[0x189f210,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: VPN plugin: requested secrets; state connect (4)
Jan 14 08:12:11 firstuser-PC NetworkManager[5004]: [1484361731.3804] vpn-connection[0x189f210,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: VPN plugin: requested secrets; state connect (4)
Jan 14 08:12:16 firstuser-PC NetworkManager[5004]: [1484361736.5644] vpn-connection[0x189f210,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: VPN plugin: requested secrets; state connect (4)
Jan 14 08:12:21 firstuser-PC NetworkManager[5004]: [1484361741.5165] vpn-connection[0x189f210,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: VPN plugin: requested secrets; state connect (4)
Jan 14 08:12:26 firstuser-PC NetworkManager[5004]: [1484361746.6401] vpn-connection[0x189f210,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: VPN plugin: requested secrets; state connect (4)
Jan 14 08:12:31 firstuser-PC NetworkManager[5004]: [1484361751.5801] vpn-connection[0x189f210,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: VPN plugin: requested secrets; state connect (4)
Jan 14 08:12:36 firstuser-PC NetworkManager[5004]: [1484361756.7951] vpn-connection[0x189f210,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: VPN plugin: requested secrets; state connect (4)
Jan 14 08:12:41 firstuser-PC NetworkManager[5004]: [1484361761.5352] vpn-connection[0x189f210,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: VPN plugin: requested secrets; state connect (4)
Jan 14 08:12:45 firstuser-PC NetworkManager[5004]: [1484361765.1531] vpn-connection[0x189f210,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: VPN connection: connect timeout exceeded.
Jan 14 08:12:45 firstuser-PC NetworkManager[5004]: [1484361765.1571] vpn-connection[0x189f210,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: VPN plugin: failed: connect-failed (1)
Jan 14 08:12:45 firstuser-PC NetworkManager[5004]: [1484361765.1571] vpn-connection[0x189f210,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: VPN plugin: state changed: stopping (5)
Jan 14 08:12:45 firstuser-PC NetworkManager[5004]: [1484361765.1572] vpn-connection[0x189f210,f936dd31-71a7-4ec9-b62b-163df07268e5,“FinchVPN”,0]: VPN plugin: state changed: stopped (6)

Hi,

The newer Network Manager unfortunately do not work well with OpenVPN. That’s not an issue with FinchVPN but the Network Manager from gnome system itself.

The current way to connect to OpenVPN is to connect via terminal by running such command.
sudo openvpn /path/that/you/save/the/openvpn/file/FinchVPN.ovpn

Replace the path to where you save the downloaded configuration.

I can connect with command line “sudo openvpn”. But are you suggesting that there is a bug or something in Mint 18 that prevents ovpn file from being importing? What is the way out?

Look at the following. I cannot connect even with command line sudo openvpn …

report:
[email protected] ~/Desktop/FN/FinchVPN_config_rsdhar_16-01-2017_ubuntu $ sudo openvpn FinchVPN_A
FinchVPN_Africa_Johannesburg_01_udp_8484_ubuntu.ovpn
FinchVPN_Asia_HongKong_01_udp_8484_ubuntu.ovpn
FinchVPN_Asia_Japan_01_udp_8484_ubuntu.ovpn
FinchVPN_Asia_Malaysia_01_udp_8484_ubuntu.ovpn
FinchVPN_Asia_Malaysia_02_udp_8484_ubuntu.ovpn
FinchVPN_Asia_Singapore_01_udp_8484_ubuntu.ovpn
FinchVPN_Asia_Singapore_03_udp_8484_ubuntu.ovpn
FinchVPN_Asia_Singapore_04_udp_8484_ubuntu.ovpn
FinchVPN_Asia_Singapore_10_udp_8484_ubuntu.ovpn
FinchVPN_Asia_Singapore_11_udp_8484_ubuntu.ovpn
[email protected] ~/Desktop/FN/FinchVPN_config_rsdhar_16-01-2017_ubuntu $ sudo openvpn FinchVPN_Asia_Singapore_03_udp_8484_ubuntu.ovpn
[sudo] password for firstuser:
Mon Jan 16 09:04:00 2017 OpenVPN 2.3.10 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [PKCS11] [MH] [IPv6] built on Feb 2 2016
Mon Jan 16 09:04:00 2017 library versions: OpenSSL 1.0.2g 1 Mar 2016, LZO 2.08
Enter Auth Username: ******
Enter Auth Password: ************
Mon Jan 16 09:04:06 2017 Initializing OpenSSL support for engine 'dynamic’
Mon Jan 16 09:04:06 2017 WARNING: file ‘finchvpn-tls-key.key’ is group or others accessible
Mon Jan 16 09:04:06 2017 Control Channel Authentication: using ‘finchvpn-tls-key.key’ as a OpenVPN static key file
Mon Jan 16 09:04:06 2017 Outgoing Control Channel Authentication: Using 160 bit message hash ‘SHA1’ for HMAC authentication
Mon Jan 16 09:04:06 2017 Incoming Control Channel Authentication: Using 160 bit message hash ‘SHA1’ for HMAC authentication
Mon Jan 16 09:04:06 2017 Socket Buffers: R=[212992->212992] S=[212992->212992]
Mon Jan 16 09:04:06 2017 UDPv4 link local: [undef]
Mon Jan 16 09:04:06 2017 UDPv4 link remote: [AF_INET]128.199.97.154:8484
Mon Jan 16 09:05:07 2017 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Mon Jan 16 09:05:07 2017 TLS Error: TLS handshake failed
Mon Jan 16 09:05:07 2017 SIGUSR1[soft,tls-error] received, process restarting
Mon Jan 16 09:05:07 2017 Restart pause, 2 second(s)
Mon Jan 16 09:05:09 2017 Socket Buffers: R=[212992->212992] S=[212992->212992]
Mon Jan 16 09:05:09 2017 UDPv4 link local: [undef]
Mon Jan 16 09:05:09 2017 UDPv4 link remote: [AF_INET]128.199.97.154:8484
Mon Jan 16 09:06:09 2017 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Mon Jan 16 09:06:09 2017 TLS Error: TLS handshake failed
Mon Jan 16 09:06:09 2017 SIGUSR1[soft,tls-error] received, process restarting
Mon Jan 16 09:06:09 2017 Restart pause, 2 second(s)
Mon Jan 16 09:06:11 2017 Socket Buffers: R=[212992->212992] S=[212992->212992]
Mon Jan 16 09:06:11 2017 UDPv4 link local: [undef]
Mon Jan 16 09:06:11 2017 UDPv4 link remote: [AF_INET]128.199.97.154:8484
Mon Jan 16 09:07:12 2017 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Mon Jan 16 09:07:12 2017 TLS Error: TLS handshake failed
Mon Jan 16 09:07:12 2017 SIGUSR1[soft,tls-error] received, process restarting
Mon Jan 16 09:07:12 2017 Restart pause, 2 second(s)
Mon Jan 16 09:07:14 2017 Socket Buffers: R=[212992->212992] S=[212992->212992]
Mon Jan 16 09:07:14 2017 UDPv4 link local: [undef]
Mon Jan 16 09:07:14 2017 UDPv4 link remote: [AF_INET]128.199.97.154:8484
Mon Jan 16 09:08:14 2017 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Mon Jan 16 09:08:14 2017 TLS Error: TLS handshake failed
Mon Jan 16 09:08:14 2017 SIGUSR1[soft,tls-error] received, process restarting
Mon Jan 16 09:08:14 2017 Restart pause, 2 second(s)
Mon Jan 16 09:08:16 2017 Socket Buffers: R=[212992->212992] S=[212992->212992]
Mon Jan 16 09:08:16 2017 UDPv4 link local: [undef]
Mon Jan 16 09:08:16 2017 UDPv4 link remote: [AF_INET]128.199.97.154:8484
Mon Jan 16 09:09:16 2017 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Mon Jan 16 09:09:16 2017 TLS Error: TLS handshake failed
Mon Jan 16 09:09:16 2017 SIGUSR1[soft,tls-error] received, process restarting
Mon Jan 16 09:09:16 2017 Restart pause, 2 second(s)
Mon Jan 16 09:09:18 2017 Socket Buffers: R=[212992->212992] S=[212992->212992]
Mon Jan 16 09:09:18 2017 UDPv4 link local: [undef]
Mon Jan 16 09:09:18 2017 UDPv4 link remote: [AF_INET]128.199.97.154:8484
Mon Jan 16 09:10:18 2017 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Mon Jan 16 09:10:18 2017 TLS Error: TLS handshake failed
Mon Jan 16 09:10:18 2017 SIGUSR1[soft,tls-error] received, process restarting
Mon Jan 16 09:10:18 2017 Restart pause, 2 second(s)
Mon Jan 16 09:10:20 2017 Socket Buffers: R=[212992->212992] S=[212992->212992]
Mon Jan 16 09:10:20 2017 UDPv4 link local: [undef]
Mon Jan 16 09:10:20 2017 UDPv4 link remote: [AF_INET]128.199.97.154:8484
Mon Jan 16 09:11:20 2017 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Mon Jan 16 09:11:20 2017 TLS Error: TLS handshake failed
Mon Jan 16 09:11:20 2017 SIGUSR1[soft,tls-error] received, process restarting
Mon Jan 16 09:11:20 2017 Restart pause, 2 second(s)
Mon Jan 16 09:11:22 2017 Socket Buffers: R=[212992->212992] S=[212992->212992]
Mon Jan 16 09:11:22 2017 UDPv4 link local: [undef]
Mon Jan 16 09:11:22 2017 UDPv4 link remote: [AF_INET]128.199.97.154:8484
Mon Jan 16 09:12:22 2017 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Mon Jan 16 09:12:22 2017 TLS Error: TLS handshake failed
Mon Jan 16 09:12:22 2017 SIGUSR1[soft,tls-error] received, process restarting
Mon Jan 16 09:12:22 2017 Restart pause, 2 second(s)
Mon Jan 16 09:12:24 2017 Socket Buffers: R=[212992->212992] S=[212992->212992]
Mon Jan 16 09:12:24 2017 UDPv4 link local: [undef]
Mon Jan 16 09:12:24 2017 UDPv4 link remote: [AF_INET]128.199.97.154:8484

Hi, there’s an issue on the latest version of Network Manager which is why Ubuntu 16.04 (using the same Network Manager) is also suffering from the same issue.

Mon Jan 16 09:05:07 2017 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)

This could be that your ISP is block the port or protocol.
Try to connect with TCP 443 and see if it works.

As far as we had tested on the same Singapore 03 UDP 8484 there’s no problem connecting to it from our side.

This is what I get when I try to connect through TCP 443 using command line:
[email protected] ~/Desktop/FN/443_tcp $ sudo openvpn FinchVPN_EU_Netherlands_05_tcp_443_ubuntu.ovpn
[sudo] password for firstuser:
Tue Jan 17 09:29:19 2017 OpenVPN 2.3.10 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [PKCS11] [MH] [IPv6] built on Feb 2 2016
Tue Jan 17 09:29:19 2017 library versions: OpenSSL 1.0.2g 1 Mar 2016, LZO 2.08
Enter Auth Username: ******
Enter Auth Password: ************
Tue Jan 17 09:29:24 2017 NOTE: --fast-io is disabled since we are not using UDP
Tue Jan 17 09:29:24 2017 Initializing OpenSSL support for engine 'dynamic’
Tue Jan 17 09:29:24 2017 WARNING: file ‘finchvpn-tls-key.key’ is group or others accessible
Tue Jan 17 09:29:24 2017 Control Channel Authentication: using ‘finchvpn-tls-key.key’ as a OpenVPN static key file
Tue Jan 17 09:29:24 2017 Outgoing Control Channel Authentication: Using 160 bit message hash ‘SHA1’ for HMAC authentication
Tue Jan 17 09:29:24 2017 Incoming Control Channel Authentication: Using 160 bit message hash ‘SHA1’ for HMAC authentication
Tue Jan 17 09:29:24 2017 Socket Buffers: R=[87380->87380] S=[16384->16384]
Tue Jan 17 09:29:24 2017 Attempting to establish TCP connection with [AF_INET]37.48.120.178:443 [nonblock]
Tue Jan 17 09:29:25 2017 TCP connection established with [AF_INET]37.48.120.178:443
Tue Jan 17 09:29:25 2017 TCPv4_CLIENT link local: [undef]
Tue Jan 17 09:29:25 2017 TCPv4_CLIENT link remote: [AF_INET]37.48.120.178:443
Tue Jan 17 09:30:26 2017 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Tue Jan 17 09:30:26 2017 TLS Error: TLS handshake failed
Tue Jan 17 09:30:26 2017 Fatal TLS error (check_tls_errors_co), restarting
Tue Jan 17 09:30:26 2017 SIGUSR1[soft,tls-error] received, process restarting
Tue Jan 17 09:30:26 2017 Restart pause, 5 second(s)
Tue Jan 17 09:30:31 2017 NOTE: --fast-io is disabled since we are not using UDP
Tue Jan 17 09:30:31 2017 Socket Buffers: R=[87380->87380] S=[16384->16384]
Tue Jan 17 09:30:31 2017 Attempting to establish TCP connection with [AF_INET]37.48.120.178:443 [nonblock]
Tue Jan 17 09:30:32 2017 TCP connection established with [AF_INET]37.48.120.178:443
Tue Jan 17 09:30:32 2017 TCPv4_CLIENT link local: [undef]
Tue Jan 17 09:30:32 2017 TCPv4_CLIENT link remote: [AF_INET]37.48.120.178:443