Help with Linux Mint 18

Followed the instructions in the video but couldn’t connect. Kept getting this fatal error message.

Here’s a copy of my terminal, any help would be great!!

[email protected]’s /etc/openvpn $ openvpn Brazil1.ovpn
Sun Jan 1 22:24:10 2017 OpenVPN 2.3.10 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [PKCS11] [MH] [IPv6] built on Feb 2 2016
Sun Jan 1 22:24:10 2017 library versions: OpenSSL 1.0.2g 1 Mar 2016, LZO 2.08
Sun Jan 1 22:24:10 2017 WARNING: file ‘account.key’ is group or others accessible
Sun Jan 1 22:24:10 2017 Initializing OpenSSL support for engine 'dynamic’
Sun Jan 1 22:24:10 2017 Control Channel Authentication: tls-auth using INLINE static key file
Sun Jan 1 22:24:10 2017 Outgoing Control Channel Authentication: Using 160 bit message hash ‘SHA1’ for HMAC authentication
Sun Jan 1 22:24:10 2017 Incoming Control Channel Authentication: Using 160 bit message hash ‘SHA1’ for HMAC authentication
Sun Jan 1 22:24:10 2017 Socket Buffers: R=[212992->212992] S=[212992->212992]
Sun Jan 1 22:24:10 2017 UDPv4 link local: [undef]
Sun Jan 1 22:24:10 2017 UDPv4 link remote: [AF_INET]181.41.217.56:53
Sun Jan 1 22:24:10 2017 TLS: Initial packet from [AF_INET]181.41.217.56:53, sid=b5cc86fb 65b641d8
Sun Jan 1 22:24:10 2017 WARNING: this configuration may cache passwords in memory – use the auth-nocache option to prevent this
Sun Jan 1 22:24:12 2017 VERIFY OK: depth=1, C=A1, ST=Anonymous, L=Anonymous, O=FinchVPN, OU=FinchVPN, CN=FinchVPN, name=FinchVPN, [email protected]
Sun Jan 1 22:24:12 2017 VERIFY OK: nsCertType=SERVER
Sun Jan 1 22:24:12 2017 VERIFY OK: depth=0, C=A1, ST=Anonymous, L=Anonymous, O=FinchVPN, OU=FinchVPN, CN=server, name=FinchVPN, [email protected]
Sun Jan 1 22:24:15 2017 Data Channel Encrypt: Cipher ‘BF-CBC’ initialized with 128 bit key
Sun Jan 1 22:24:15 2017 Data Channel Encrypt: Using 160 bit message hash ‘SHA1’ for HMAC authentication
Sun Jan 1 22:24:15 2017 Data Channel Decrypt: Cipher ‘BF-CBC’ initialized with 128 bit key
Sun Jan 1 22:24:15 2017 Data Channel Decrypt: Using 160 bit message hash ‘SHA1’ for HMAC authentication
Sun Jan 1 22:24:15 2017 Control Channel: TLSv1.2, cipher TLSv1/SSLv3 DHE-RSA-AES256-GCM-SHA384, 2048 bit RSA
Sun Jan 1 22:24:15 2017 [server] Peer Connection Initiated with [AF_INET]181.41.217.56:53
Sun Jan 1 22:24:17 2017 SENT CONTROL [server]: ‘PUSH_REQUEST’ (status=1)
Sun Jan 1 22:24:17 2017 PUSH: Received control message: 'PUSH_REPLY,redirect-gateway def1 bypass-dhcp,dhcp-option DNS 8.8.4.4,dhcp-option DNS 8.8.8.8,route-method adaptive,route-delay 1,route-metric 1,route 25.52.30.1,topology net30,ping 10,ping-restart 60,ifconfig 25.52.31.34 25.52.31.33’
Sun Jan 1 22:24:17 2017 OPTIONS IMPORT: timers and/or timeouts modified
Sun Jan 1 22:24:17 2017 OPTIONS IMPORT: --ifconfig/up options modified
Sun Jan 1 22:24:17 2017 OPTIONS IMPORT: route options modified
Sun Jan 1 22:24:17 2017 OPTIONS IMPORT: route-related options modified
Sun Jan 1 22:24:17 2017 OPTIONS IMPORT: --ip-win32 and/or --dhcp-option options modified
Sun Jan 1 22:24:17 2017 ROUTE_GATEWAY 192.168.0.1/255.255.255.0 IFACE=wlp3s0 HWADDR=e4:ce:8f:2d:46:fa
Sun Jan 1 22:24:17 2017 ERROR: Cannot ioctl TUNSETIFF tun: Operation not permitted (errno=1)
Sun Jan 1 22:24:17 2017 Exiting due to fatal error

Sun Jan 1 22:24:17 2017 ERROR: Cannot ioctl TUNSETIFF tun: Operation not permitted (errno=1)

You need to run it with root permission.

Try run it again with this command instead.
[email protected]’s /etc/openvpn $ sudo openvpn Brazil1.ovpn

So I ran it with root and it worked but I can’t browse the internet or do anything online. It just keeps connecting in firefox. I tried to ping Google’s servers from a terminal but nothing happens. As soon as I turn off the VPN I get replies from my provider on my Google ping. Any ideas?

Does it happen as well if you connect to a different server?
Or perhaps on the same server but different port/protocol?