Can someone please make a DD-WRT how to for finchvpn this is where i got

#!/bin/sh

USERNAME="USERNAME_HERE"
PASSWORD="API_KEY_HERE"
PROTOCOL="udp"

# Add - delete - edit servers between ##BB## and ##EE##
REMOTE_SERVERS="
##BB##
# 4g test - UDP
remote 104.36.80.101 53
remote free-05.protectednetgroup.com 53
##EE##
"

#### DO NOT CHANGE below this line ####

CA_CRT='-----BEGIN CERTIFICATE-----
MIIE3DCCA8SgAwIBAgIJAPIqWEGY5xAiMA0GCSqGSIb3DQEBBQUAMIGkMQswCQYD
VQQGEwJBMTESMBAGA1UECBMJQW5vbnltb3VzMRIwEAYDVQQHEwlBbm9ueW1vdXMx
ETAPBgNVBAoTCEZpbmNoVlBOMREwDwYDVQQLEwhGaW5jaFZQTjERMA8GA1UEAxMI
RmluY2hWUE4xETAPBgNVBCkTCEZpbmNoVlBOMSEwHwYJKoZIhvcNAQkBFhJhZG1p
bkBmaW5jaHZwbi5jb20wHhcNMTIxMjAyMDM1MjE1WhcNMjIxMTMwMDM1MjE1WjCB
pDELMAkGA1UEBhMCQTExEjAQBgNVBAgTCUFub255bW91czESMBAGA1UEBxMJQW5v
bnltb3VzMREwDwYDVQQKEwhGaW5jaFZQTjERMA8GA1UECxMIRmluY2hWUE4xETAP
BgNVBAMTCEZpbmNoVlBOMREwDwYDVQQpEwhGaW5jaFZQTjEhMB8GCSqGSIb3DQEJ
ARYSYWRtaW5AZmluY2h2cG4uY29tMIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIB
CgKCAQEAtJJ6OjuZisK1wAew0p1l6kAKj5QKtg6l3X8tMcI0S8oQ/ZnDKQzxKnUt
vWFqXNaZqzIKA5DCSJbTuHktuI6VYSkCwE9ufuVcHUlI8WSD87qK1qAEFIsg0XOg
4crF1Hh9WDrJmvUdXmPuhAa9XmYuwL7x+bnF/MIYvXTHekXW1GwXAfOUhe7Aturi
0xnItOzg95gFrUa87F3VH3oJ02EP82/h4avNi3dFm0HmmaMtKlDoAN3H8QZFXpA7
3bEe4bM1RY0S4uB07/1+o5g4rKueLxZar2ij1tcUI84ZufkgyHLU9pqIJT87Uxjw
61Q6NpNj1Vu+gKsHc1msmnnqz3cUkQIDAQABo4IBDTCCAQkwHQYDVR0OBBYEFHx4
P3DljtDxFipih6RfxgUD9CkCMIHZBgNVHSMEgdEwgc6AFHx4P3DljtDxFipih6Rf
xgUD9CkCoYGqpIGnMIGkMQswCQYDVQQGEwJBMTESMBAGA1UECBMJQW5vbnltb3Vz
MRIwEAYDVQQHEwlBbm9ueW1vdXMxETAPBgNVBAoTCEZpbmNoVlBOMREwDwYDVQQL
EwhGaW5jaFZQTjERMA8GA1UEAxMIRmluY2hWUE4xETAPBgNVBCkTCEZpbmNoVlBO
MSEwHwYJKoZIhvcNAQkBFhJhZG1pbkBmaW5jaHZwbi5jb22CCQDyKlhBmOcQIjAM
BgNVHRMEBTADAQH/MA0GCSqGSIb3DQEBBQUAA4IBAQBiJXoupHZKZz3YpPVzN58U
Wf4gNGM6u1GpXl/YDavaxT5zSYB35kEx+yf3qzAM9b7h4BnN7RnqCyG4LNxfz8eN
w/6f6fNs6p7AGsscEBYO29Z7/La7N11QLzUEil6eyAnC1qOd1gQJgMOJH7e96Q2r
e7jvsPaXsTsF3MxMlG575sD1T3gki0ryPN06MJwowM+VF40fXMkV78dpXGXR4cu2
c3oZeDN6AZpt0LupzyWHaheepZnDiDlVxof4vkvWuHwnPENkf1Yk3COzsCTVKakg
mMezklCXJQrrEU8STSmAgEUeO00CyHKIf3jBq6vEey/e5tDvCDATQzqpsE9OWMU+
-----END CERTIFICATE-----'

TLS_AUTH='-----BEGIN OpenVPN Static key V1-----
36e6ccb747ea6c898755e1fe8232d739
b07fb251216efb9925f79060731666c4
0840f4ec0436cfc487044a6a0a0d1129
1554817e0a7672f7c61a887ba4118b39
acbec7c49571911a32d698099f7755ce
119741516b1c04e85992ea0032b981a0
2f8d51252a4a06723f3de68b4a2cd488
e38b4323608deccf0329a88753f18073
463c0c519ad38ec8eb44d81751e7773d
d650c3576c28813f785bd988a1015f67
17ab85b23e49634782391a8196a788a0
89170a60ee151adadd50c67ecc9e18d1
aab779ac4337e214088875b89d801cad
7dfcdc706d1ed3a60757db1d43b03802
a33b6a91dfa97e224a687dd3adb7f66c
cc0b0778639d894dba4357a8183407cf
-----END OpenVPN Static key V1-----'


OPVPNENABLE=`nvram get openvpncl_enable | awk '$1 == "0" {print $1}'`

if [ "$OPVPNENABLE" != 0 ]
then
nvram set openvpncl_enable=0
nvram commit
fi

sleep 30
mkdir /tmp/finchvpncl; cd /tmp/finchvpncl
echo -e "$USERNAME\n$PASSWORD" > userpass.conf
echo "$CA_CRT" > ca.crt; echo "$TLS_AUTH" > ta.key
echo "#!/bin/sh" > route-up.sh; echo -e "#!/bin/sh\nsleep 2" > route-down.sh
echo "#!/bin/sh
iptables -I FORWARD -i br0 -o tun0 -j ACCEPT
iptables -I FORWARD -i tun0 -o br0 -j ACCEPT
iptables -I INPUT -i tun0 -j REJECT
iptables -t nat -A POSTROUTING -o tun0 -j MASQUERADE" > /tmp/.rc_firewall
chmod 644 ca.crt ta.key; chmod 600 userpass.conf; chmod 700 route-up.sh route-down.sh
chmod 700 /tmp/.rc_firewall
sleep 30
echo "client
dev tun
proto $PROTOCOL
resolv-retry infinite
nobind
tls-client
tls-auth ta.key 1
persist-tun
persist-key
ca ca.crt
cipher BF-CBC
engine dynamic
auth-user-pass userpass.conf
auth-nocache
ns-cert-type server
comp-lzo adaptive
explicit-exit-notify 2
verb 3
mute-replay-warnings
reneg-sec 31557600
log finchvpn.log
daemon
remote-random

$REMOTE_SERVERS" > openvpn.conf
ln -s /tmp/Finchvpncl/Finchvpn.log /tmp/Finchvpn.log
(killall openvpn; openvpn --config /tmp/Finchvpncl/openvpn.conf --route-up /tmp/Finchvpncl/route-up.sh --down-pre /tmp/Finchvpncl/route-down.sh) &
exit 0

Hello,

Please try this updated DD-WRT script and let me know the result.
https://www.finchvpn.com/config/openvpn/ddwrt

1 Like

ok thanks amo try this and let you know it it works

well ave been at it for about 4 to 4/30hr now and still nothing i copped and paste it in the Command Shell nothing happen i tried saving it to the start up nothing happen i ssh in the the ddwrt router to see if anything happen no finchvpn openvpn config or files to be found am still tried to find out whats wrong well i would upload a screen shot but its telling me that new user cant upload screen shots even tho ave been a user for 3 years now

1 Like

After you have copy and excuted the script you have to wait 30 seconds for the script to finish run. The configuration file is located at /tmp/finchvpn

You are not able to upload image because you are new to this discussion forum (it’s different from FinchVPN website), I recommend you to upload to external image sharing website.

ok am going to try it again the only time i see the config the the ddwrt tap time is when i manually put it in the OpenVPN Client ok am going to try to find a set to upload the pic to


oh one more thing all i need to do it just to run it that’s all right ? or do i need to do something else ?


sigh now its telling me that new user cant put images
post so i cant show Anything and i tried wait the 30 sec didnt work waited 5 minuts still nothing

Access the DD-WRT router’s web configuration interface by browsing to http://192.168.1.1.
These are some of the most common default IP addresses: 192.168.1.1 / 192.168.2.1 / 192.168.11.1 / 192.168.10.1 or 192.168.30.1.

On the top right, you’ll see the DD-WRT firmware version.
Basically, there are the following firmware versions: MICRO, MINI, STD, BIG, MEGA.
If you wish to use OpenVPN as your protocol for connecting to the VPN, you must use BIG or MEGA versions; or at least STD.
OpenVPN is not included in MICRO or MINI firmware versions, so with them you can only use PPTP or L2TP protocol.

Click Administration -> Commands and paste ALL of the text you’ve downloaded from the config generator.

Make sure you paste everything between ‘#/bin/sh’ and 'exit 0’ – ensure that your FinchVPN username and password are correct.

Now click the ‘Save Startup’ button towards the bottom of the screen.

Next click Administration -> Management, and click the ‘Reboot Router’ button from the bottom.

Give the device a few mins to come back up.

Firmware:
DD-WRT v24-sp2 (04/14/14) vpnkong and yes it has openvpn client and domain and yes i have run vpn on it b4 i used hidemyassvpn i would show you my set up but like i told you i cant upload or link screenshots

Please download the new config from our generator again, the current version will be ver 1.0.1

After you have paste it, press ‘Save Startup’

You can email to screenshot to [email protected]

ok am going to do that right now

hay thanks for the new updated DD-WRT config its working now but i cant get any internet from the Wireless only the LAN i think it has something to do with the DHCP but am not 100% can i het some help with that ?

hay can i please get some help i have to using a static ip to get internet on the Wireless but the problem is not all devices give the option to input a static so i cant get them to connect to the ddwrt router please help

Hi. Can anybody help me how to set pptp in ddwrt modem configuration?

failed to connect. as can get any more info to setup.

Did you use your username and your API key as password?

Yes. And i keep generate the API after the prev API not working. Do i need to fill in the remote subnet etc? What is it?

After you have changed your API key, you have to wait 15 minutes for the data to be updated across the servers.

Can you try again on another server ? As for the subnet we will confirm with you later on.

Ok i’ll try it again on monday. Left the modem at the office. Will update later. Tq for all reply

Oh btw, by means not change the subnet etc, so i just need to let it with 0 value like the screenshot? Or i need to delete everythings except server ip & user id+ password?